Proper support for Sponge and its plugins?

  • 89 Views
  • Last Post 07 May 2017
Mopar posted this 06 May 2017

I am really liking the layout of AMP, but I notice that when selecting sponge as a jar file, it tries to run it as a server jar, which it is not (its a mod file). Although I do greatly like its ease of being able to select it, its version, etc, would it be possible to have it listed as a separate jar and have it installed in the mods folder and not in the root folder to be launched as a server jar file?

Also, I do love how spigot is integrated, it makes finding plugins ALOT easier. Is their any plans on implementing Sponge plugins in the same or similar way?

2 Comments
Order By: Standard | Newest | Votes
Mike posted this 06 May 2017

I don't think Sponge has a central plugin repository with an API, unless that exists then it's not likely to happen. I need to re-do the sponge support as originally you could just run the Jar directly.

Mopar posted this 07 May 2017

Mike -

You are correct, they don't have a central repository. Currently their plugins are in 2 different locations to where you can download them.

As for re-doing how its listed in AMP, that will be a trick. The vanilla sponge might be ran directly (havent tried), but sponge-forge can not. (Sorry, I should have been more clear about that in my 1st post.)

The other issue with sponge is that if you are running a minecraft server 1.10.x or older, a wrapper needs to be used for it to work properly (its nothing on AMPs end, this is all on java/forge/minecraft/sponge), and for that to work, you need to be sure that the version of sponge matches the version of MC and forge.....in short, it might be something to just have sponge labled as 'Experimental' until things become more unifed.

Enough rambling. Thanks for your hard work and AMP is shaping up really, really nicely!