Cant start main instance anymore

  • 84 Views
  • Last Post 2 days ago
Lyvondria posted this 1 weeks ago - Last edited 1 weeks ago

Hey,

I have a problem. I cant start the main instance anymore. When I type: ./ampinstmgr StartInstance ADSInstance it just says this:

[Info] AMP Instance Manager v1.4.6.0 [Info] Starting Instance: 'ADSInstance' [Debug] Running /usr/bin/tmux -f /dev/null new-session -s "AMPADSInstance" -d "cd '/home/AMP/.ampdata/instances/ADSInstance' --; /home/AMP/.ampdata/instances/ADSInstance/AMPLinuxx8664 " [Debug] Starting process /usr/bin/tmux [Debug] Working Directory: /home/AMP/.ampdata/instances/ADSInstance [Debug] Arguments: -f /dev/null new-session -s "AMPADSInstance" -d "cd '/home/AMP/.ampdata/instances/ADSInstance' --; /home/AMP/.ampdata/instances/ADSInstance/AMPLinuxx8664 " [Info] Created session. Run './ampinstmgr Attach ADSInstance' to attach.

And the intance is not starting.... Whats wrong? Then when I type: ./ampinstmgr Attach ADSInstance it says: [Notice] ADSInstance is not running.

What do I do?

This is the log file:

[18:16:53] [Core:Core Info]       : Starting AMP version 1.4.6.9, built 2017-03-31 19:33 [18:16:53] [Core:Core Info]       : OS: Linux / x8664 [18:16:53] [Core:Core Info]       : AMP Instance ID: babd5267-ffc1-424c-954a-a05c928319b2 [18:16:54] [ModuleShared:Core Error] : Got a bad hardware address length for an AFPACKET 16 8 [18:16:54] [ModuleLoader:Core Info] : Loading Module: ADSModule [18:16:54] [ModuleShared:Core Error] : Got a bad hardware address length for an AF_PACKET 16 8 [18:16:54] [ModuleLoader:Core Info] : Loaded ADSModule version 1.0.0.0 [18:16:54] [ModuleLoader:Core Info] : - Author: CubeCoders Limited [18:16:54] [ModuleLoader:Core Info] : - For Application Deployment application. [18:16:54] [ModuleLoader:Core Info] : - Does not support sleeping. [18:16:54] [ModuleLoader:Core Info] : Loading Plugin: BannerImagePlugin [18:16:54] [ModuleLoader:Core Info] : Loaded BannerImagePlugin version 1.0.0.0 [18:16:54] [ModuleLoader:Core Info] : - Author: CubeCoders Limited [18:16:54] [Scheduler:Core Debug] : BannerImagePlugin registered event ImageUpdated (The status image has been updated.) [18:16:54] [ModuleLoader:Core Info] : Loading Plugin: EmailSender [18:16:54] [ModuleLoader:Core Info] : Loaded EmailSender version 1.0.0.0 [18:16:54] [ModuleLoader:Core Info] : - Author: CubeCoders Limited [18:16:54] [Scheduler:Core Debug] : EmailSender registered task SendMail [18:16:54] [ModuleLoader:Core Info] : Loading Plugin: FileManager [18:16:54] [ModuleLoader:Core Info] : Loaded FileManager version 1.0.0.0 [18:16:54] [ModuleLoader:Core Info] : - Author: CubeCoders Limited [18:16:54] [ModuleLoader:Core Info] : Loading Plugin: PushBulletPlugin [18:16:54] [ModuleLoader:Core Info] : Loaded PushBulletPlugin version 1.0.0.0 [18:16:54] [ModuleLoader:Core Info] : - Author: CubeCoders Limited [18:16:54] [Scheduler:Core Debug] : PushBulletPlugin registered task PushMessage [18:16:54] [Scheduler:Core Debug] : PushBulletPlugin registered task PushMessageChannel [18:16:54] [ModuleLoader:Core Info] : Loading Plugin: LocalFileBackupPlugin [18:16:54] [LocalFileBackupPlugin:Core Debug] : Read manifests for 0 backups. [18:16:54] [FeatureManager:Core Debug] : LocalFileBackupPlugin registered feature BackupProvider [18:16:54] [ModuleLoader:Core Info] : Loaded LocalFileBackupPlugin version 1.0.0.0 [18:16:54] [ModuleLoader:Core Info] : - Author: CubeCoders Limited [18:16:54] [Scheduler:Core Debug] : LocalFileBackupPlugin registered event TakeBackupComplete (A backup finishes archiving.) [18:16:54] [Scheduler:Core Debug] : LocalFileBackupPlugin registered event RestoreBackupComplete (A backup finishes restoring.) [18:16:54] [Scheduler:Core Debug] : LocalFileBackupPlugin registered task TakeBackup [18:16:54] [ModuleLoader:Core Info] : ADSModule requests dependency InstanceManagerPlugin... [18:16:54] [ModuleLoader:Core Info] : Loading Plugin: InstanceManagerPlugin [18:16:54] [InstanceManagerPlugin:Core Debug] : Loading instances from /home/AMP/.ampdata/instances.json... [18:16:54] [InstanceManagerPlugin:Core Debug] : Loaded 2 instances. [18:16:54] [FeatureManager:Core Debug] : InstanceManagerPlugin registered feature LocalInstanceManager [18:16:54] [ModuleLoader:Core Info] : Loaded InstanceManagerPlugin version 1.0.0.0 [18:16:54] [ModuleLoader:Core Info] : - Author: CubeCoders Limited [18:16:54] [ModuleLoader:Core Info] : ADSModule requests dependency steamcmdplugin... [18:16:54] [ModuleLoader:Core Info] : Loading Plugin: steamcmdplugin [18:16:55] [FeatureManager:Core Debug] : steamcmdplugin registered feature steamcmdhelper [18:16:55] [ModuleLoader:Core Info] : Loaded steamcmdplugin version 1.0.0.0 [18:16:55] [ModuleLoader:Core Info] : - Author: CubeCoders Limited [18:16:55] [Scheduler:Core Debug] : steamcmdplugin registered event UpdateAvailable (An update is available) [18:16:55] [Scheduler:Core Debug] : steamcmdplugin registered task CheckForUpdates [18:16:55] [ModuleLoader:Core Info] : ADSModule requests dependency SystemUserManagerPlugin... [18:16:55] [ModuleLoader:Core Info] : Loading Plugin: SystemUserManagerPlugin [18:16:55] [FeatureManager:Core Debug] : SystemUserManagerPlugin registered feature LinuxUserManager [18:16:55] [ModuleLoader:Core Info] : Loaded SystemUserManagerPlugin version 1.0.0.0 [18:16:55] [ModuleLoader:Core Info] : - Author: CubeCoders Limited [18:16:55] [Core:Core Error]      : AMP may not run without a licence.

7 Comments
Order By: Standard | Newest | Votes
Mike posted this 1 weeks ago

Reactivate the instance:

./AMP_Linux_x86_64 +Core.AMP.LicenceKey YOURKEYGOESHERE -configonly

Lyvondria posted this 1 weeks ago

Thank you! worked!

rjwboys posted this 5 days ago

do i have to do this every time i reboot my server?

Mike posted this 5 days ago

Nope, if you're making AMP start automatically on boot you have to delay its startup by about a minute.

rjwboys posted this 3 days ago

well everytime i manual start the instance after rebooting computer says it doesn't have a licence key so i have to run that command

Lyvondria posted this 3 days ago - Last edited 3 days ago

Okey, it works but now I get an "Error?" called:

[11:56:04] [ModuleShared:Core Error] : Got a bad hardware address length for an AFPACKET 16 8 [11:56:04] [ModuleShared:Core Error] : Got a bad hardware address length for an AFPACKET 16 8 [11:56:04] [ModuleShared:Core Error] : Got a bad hardware address length for an AF_PACKET 16 8

But the Instance is running.

I have also another Question. If I tried to start the ADSInstance, I had also to reactivate the other Instance for make it to run. So when I want to create a NEW Instance for like Minecraft, do I have to activate them everytime or can I create an Instance again in the ADSInstance Admin Panel?

Mike posted this 2 days ago

That error is safe to ignore.

I don't follow you on the second question, could you elaborate further?