Are the AMP requirements a must?

  • 52 Views
  • Last Post 2 weeks ago
Andrewzz posted this 2 weeks ago

It seems a bit much 20Gb of storage and 8Gb RAM to use only the Minecraft module for a server to play with my friends.

4 Comments
Order By: Standard | Newest | Votes
Mike posted this 2 weeks ago

No that's just a recommendation based on having multiple servers.

Andrewzz posted this 2 weeks ago - Last edited 2 weeks ago

Thanks Mike!

I'm now trying to install the McMyAdmin module, but it just hangs at one step.

[ec2-user@machine AMP]$ ./ampinstmgr CreateInstance McMyAdmin MCMA 0.0.0.0 8080 EditedKEY EditedPSW +Core.Login.Username EditedUSER  
[Info] AMP Instance Manager v1.4.4.0    
[Info] Checking licence key...  
[Info] Waiting...  
[Info] Licence Type:  McMyAdmin Professional  
[Info] Current Usage: 0  
[Info] Creating Instance: 'MCMA'  
[Info] Performing Step: Creating Environment  
[Debug] User: ec2-user  
[Debug] Home Dir: /home/ec2-user  
[Info] Performing Step: Downloading AMP  
[Debug] User: ec2-user  
[Debug] Home Dir: /home/ec2-user  
[Info] Performing Step: Unpacking  
[Debug] Running command line: "unzip -qq -o "/home/ec2-user/.ampdata/instances/AMPCache-1440.zip"" from "/home/ec2-user/.ampdata/instances/MCMA"  
[Info] Performing Step: Configuring AMP  
[Debug] Updating Permissions...  
[Debug] Starting process /bin/chmod  
[Debug] Working Directory: /home/ec2-user/.ampdata/instances/MCMA  
[Debug] Arguments: +x "/home/ec2-user/.ampdata/instances/MCMA/AMP_Linux_x86_64"  

It has been at that step for like 30 minutes now

Mike posted this 2 weeks ago

Funny coincidence, someone else on EC2 had this problem. Fix is to yum update and upgrade, restart the instance and follow the instructions when they tell you to make a new user.

Andrewzz posted this 2 weeks ago

It was actually me :D
What did fix the issue was, when the process seems to hang, just to kil it (CTRL+C) and run it again. It completed without issues for me after that.
Why it hang? I don't know, but that happened twice to me.