[solved] how to create multiple mcma instances with AMP

  • 57 Views
  • Last Post 18 August 2017
  • Topic Is Solved
omtr posted this 18 August 2017

Hi, i created two instances, both listening on 0.0.0.0, the first on port 1337, the 2nd on port 1338:

sh-4.3$ ./ampinstmgr -l
[Info] AMP Instance Manager v1.4.8.2
[Debug] Starting process /sbin/ldconfig
[Debug] Working Directory: /home/AMP/AMP
[Debug] Arguments: -p
[Debug] Started process with ID 10644
[Debug] Starting process /bin/uname
[Debug] Working Directory: /home/AMP/AMP
[Debug] Arguments: -m
[Debug] Started process with ID 10652
[Debug] Loading instances from /home/AMP/.ampdata/instances.json...
[Debug] Loaded 2 instances.
Instance ID      │ c91b8cb1-b62e-4249-ab09-b86acecb48f1
Module           │ McMyAdmin
Instance Name    │ MCMA
Friendly Name    │ MCMA
IP Binding       │ 0.0.0.0
Port Number      │ 1337
Running          │ Yes
Daemon Installed │ No
Start on Boot    │ No
AMP Version      │ 1.4.7.2
Data Path        │ /home/AMP/.ampdata/instances/MCMA

Instance ID      │ 0f68a911-819f-408d-8a74-0910d9e62151
Module           │ McMyAdmin
Instance Name    │ mc02
Friendly Name    │ mc02
IP Binding       │ 0.0.0.0
Port Number      │ 1338
Running          │ No
Daemon Installed │ No
Start on Boot    │ No
AMP Version      │ 1.4.8.2
Data Path        │ /home/AMP/.ampdata/instances/mc02

Unfortunately i cannot access the web interface on the 2nd instance, i get a timeout. netstat tells me that there is not process listening on port 1338. maybe its not possible to start 2 mcma instances? i cannot find any logfiles, could you point me to the right place?

omtr posted this 18 August 2017

solved it: the minecraft server in the 2nd instance listened on the default port. after changing it i was able to access the AMP web interface.

Close