Updating ampinstmgr on linux breaks the catalog of installed instances

  • 80 Views
  • Last Post 4 days ago
mercsniper posted this 2 weeks ago - Last edited 2 weeks ago

[AMP@puppetmaster AMP]$ ./ampinstmgr -l
[Info] AMP Instance Manager v1.4.6.4
Instance ID │ 956bf325-3c1a-45ff-b28f-23244942b985
Module │ ADS
Instance Name │ ADSInstance
Friendly Name │ ADSInstance
IP Binding │ 0.0.0.0
Port Number │ 8080
Running │ No
Damon Installed │ No
Start on Boot │ Yes
AMP Version │ 1.4.6.4
Data Path │ /home/AMP/.ampdata/instances/ADSInstance

Instance ID │ 949bc00f-01cd-4b81-80a4-acf6b5c48707
Module │ McMyAdmin
Instance Name │ 1-McMyAdmin
Friendly Name │ 1-McMyAdmin
IP Binding │ 0.0.0.0
Port Number │ 8081
Running │ No
Damon Installed │ No
Start on Boot │ No
AMP Version │ 1.4.6.4
Data Path │ /home/AMP/.ampdata/instances/1-McMyAdmin

[AMP@puppetmaster AMP]$ ./ampinstmgr -a [Info] AMP Instance Manager v1.4.6.4

Unhandled Exception: System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.

5 Comments
Order By: Standard | Newest | Votes
Mike posted this 2 weeks ago

There's a known issue with v1464 of the instance manager. You can download the previous version in the meanwhile: https://cubecoders.com/Downloads/1440/ampinstmgr.zip

Mike posted this 2 weeks ago

There's a new version available - v1465 which fixes the instance manager again.

Gibbsman posted this 5 days ago - Last edited 5 days ago

I was running 1400 from Oct, stopped the instances and upgraded to 1465 and upgraded all instances. When I try to start all instances I still get the same errors above.

I did try downloading the 1440 version but I couldn't figure out how to downgrade the instances from 1465 to 1440. Doing the -p didn't work.

Is there anyway to fix the instances without rebuilding from scratch?

Note: I tried starting the instances individually and it seems to only pertain to Minecraft instances. My Starbound instance started correctly.

Update: Apparently if I start each one individually using -s then they all start correctly with 1465. It's only if I do a -a that I get the errors listed by OP.

Mike posted this 4 days ago

What happens if you start the instances manually outside of the instance manager?