Not able to make backups for minecraft server

  • 105 Views
  • Last Post 20 April 2017
phil71185 posted this 12 January 2017 - Last edited 12 January 2017

I am not able to make a backup on my server it says the backup has started then the console shows the following error log. Any ideas? Running as a non admin user not as a service on windows server 2012.

[18:37:03] [LocalFileBackupPlugin:Core Info] : Creating Backup: Server
[18:37:03] [LocalFileBackupPlugin:Core Debug] : Building file list...
[18:37:04] [LocalFileBackupPlugin:Core Debug] : File list built: 15214 files totaling 757MB
[18:37:04] [LocalFileBackupPlugin:Core Debug] : Checking cycling requirements...
[18:37:04] [LocalFileBackupPlugin:Core Debug] : Checkpoint ALPHA
[18:37:04] [LocalFileBackupPlugin:Core Debug] : Adding files to archive...
[18:37:08] [LocalFileBackupPlugin:Core Debug] : Saving archive...
[18:37:08] [LocalFileBackupPlugin:Core Debug] : Error writing backup: Index was outside the bounds of the array.
[18:38:13] [LocalFileBackupPlugin:Core Info] : Creating Backup: Server
[18:38:13] [LocalFileBackupPlugin:Core Debug] : Building file list...
[18:38:14] [LocalFileBackupPlugin:Core Debug] : File list built: 15214 files totaling 757MB
[18:38:14] [LocalFileBackupPlugin:Core Debug] : Checking cycling requirements...
[18:38:14] [LocalFileBackupPlugin:Core Debug] : Checkpoint ALPHA
[18:38:14] [LocalFileBackupPlugin:Core Debug] : Adding files to archive...
[18:38:19] [LocalFileBackupPlugin:Core Debug] : Saving archive...
[18:38:19] [LocalFileBackupPlugin:Core Debug] : Error writing backup: Index was outside the bounds of the array.

  • Liked by
  • Akaitatsu
5 Comments
Order By: Standard | Newest | Votes
Akaitatsu posted this 19 April 2017 - Last edited 19 April 2017

I am having this problem as well, or at least something similar.

Here is the log entry:

[16:16:23] [LocalFileBackupPlugin:Core Info] : Creating Backup: Manual
[16:16:23] [LocalFileBackupPlugin:Core Debug] : Building file list...
[16:16:23] [LocalFileBackupPlugin:Core Debug] : File list built: 1457 files totaling 1486MB
[16:16:23] [LocalFileBackupPlugin:Core Debug] : Checking cycling requirements...
[16:16:23] [LocalFileBackupPlugin:Core Debug] : Adding files to archive...
[16:16:23] [LocalFileBackupPlugin:Core Debug] : Saving archive...
[16:16:23] [LocalFileBackupPlugin:Core Debug] : Error writing backup: Index was outside the bounds of the array.

There are no backup files in the Backups folder. Here is what little content there is in the Backups.json file.

{}

I tried deleting the Backups.json file but got the exact same error in the log.

Akaitatsu posted this 19 April 2017

It's working for me now. I am not entirely sure why but I think I have it narrowed down to one of two things.

  • I re-created the Backups.json file so maybe it was something wrong with the old file.
  • There may have been some kind of invalid character in the Description field. I don't remember what I had entered for it when I was getting the failure. I have since tried a really long description and it still worked.

Akaitatsu posted this 19 April 2017

Hey! I got it to break again. I am submitting all the info (now that I have seen the recommended template for submitting a problem).

OS Name/Version: Windows Server 2012 R2

Product Name/Version: AMP Release "TN/SR0" v1.4.6.9, built 2017-03-31 19:33

Problem Description: Manual backups fail with no notification in the GUI

Steps to reproduce:

  1. Take a backup manually
  2. Take another backup (yes, you need two)
  3. Delete one of the backups through the GUI
  4. Try to take another manual backup; the progress info shows up briefly and closes with no explanation

Actions taken to resolve so far:

I have found three different things that fix the problem temporarily

  • Deleted and added back an empty Backups.json file (curly brackets only) after manually deleting all the backup files
  • Deleted all the backups through the GUI and it started working again
  • Refreshed the Backup page by clicking the Backup menu item

It seems like there is a problem with the data loaded in the web page not being in sync with the Backups.json file. It's been pretty inconsistent in general so I am just confused now.

Mike posted this 19 April 2017

Do you have multiple files with the same name but a different casing?

Akaitatsu posted this 20 April 2017

Do you have multiple files with the same name but a different casing?

No, I am on Windows which won't let you do that since it is case-insensitive.

After you posted, Mike, I ran a couple more backups. Then I deleted the only backup that existed before I created those. Finally, I tried another manual backup and it failed.

Backups.json contents (all one line):

{"b4bd2888-1e91-46f9-8819-01d2be9f6ea8":{"Id":"b4bd2888-1e91-46f9-8819-01d2be9f6ea8","Timestamp":"2017-04-19T20:21:50.2169163-04:00","ModuleName":"MinecraftModule","TakenBy":"Admin","Name":"Manual","Description":"Because I said so and I want to try a really really really long description to see if I can break this.","META":null,"TotalSizeBytes":1561777522,"Sticky":false},"8d63b07e-a3c9-4dd1-9ee1-d1ff37284f91":{"Id":"8d63b07e-a3c9-4dd1-9ee1-d1ff37284f91","Timestamp":"2017-04-19T20:23:41.9193969-04:00","ModuleName":"MinecraftModule","TakenBy":"Admin","Name":"Manual","Description":"Because I said so and I want to try a really really really long description to see if I can break this.","META":null,"TotalSizeBytes":1561867007,"Sticky":false}}

Current files in the Backups folder:

  • 20170419-202150-b4bd28881e9146f9881901d2be9f6ea8.zip
  • 20170419-202341-8d63b07ea3c94dd19ee1d1ff37284f91.zip

Log entries for the backup operations (note that the Delete isn't logged):

[20:21:50] [LocalFileBackupPlugin:Core Info] : Creating Backup: Manual
[20:21:50] [LocalFileBackupPlugin:Core Debug] : Building file list...
[20:21:50] [LocalFileBackupPlugin:Core Debug] : File list built: 1457 files totaling 1489MB
[20:21:50] [LocalFileBackupPlugin:Core Debug] : Checking cycling requirements...
[20:21:50] [LocalFileBackupPlugin:Core Debug] : Adding files to archive...
[20:21:50] [LocalFileBackupPlugin:Core Debug] : Saving archive...
[20:23:31] [LocalFileBackupPlugin:Core Debug] : Backup complete.
[20:23:41] [LocalFileBackupPlugin:Core Info] : Creating Backup: Manual
[20:23:41] [LocalFileBackupPlugin:Core Debug] : Building file list...
[20:23:42] [LocalFileBackupPlugin:Core Debug] : File list built: 1457 files totaling 1489MB
[20:23:42] [LocalFileBackupPlugin:Core Debug] : Checking cycling requirements...
[20:23:42] [LocalFileBackupPlugin:Core Debug] : Adding files to archive...
[20:23:42] [LocalFileBackupPlugin:Core Debug] : Saving archive...
[20:25:20] [LocalFileBackupPlugin:Core Debug] : Backup complete.
[20:27:24] [LocalFileBackupPlugin:Core Info] : Creating Backup: Manual
[20:27:24] [LocalFileBackupPlugin:Core Debug] : Building file list...
[20:27:24] [LocalFileBackupPlugin:Core Debug] : File list built: 1457 files totaling 1489MB
[20:27:24] [LocalFileBackupPlugin:Core Debug] : Checking cycling requirements...
[20:27:24] [LocalFileBackupPlugin:Core Debug] : Adding files to archive...
[20:27:24] [LocalFileBackupPlugin:Core Debug] : Saving archive...
[20:27:24] [LocalFileBackupPlugin:Core Debug] : Error writing backup: Index was outside the bounds of the array.

Let me know if there is anything else I can get or do to help out with this.